damnedsky
Posts: 4
Joined: Sat Jul 25, 2015 1:14 am

Audio snags in recordings when using AAC codec

Mon Jul 27, 2015 9:05 pm

Hello!

The situation present in this message was observed with Bandicam v2.2.3. I did not get the chance to test the new version. I will update this topic as soon as I test it.

This situation was observed in multiple games: Minecraft, The Witcher Wild Hunt, Heroes of the Storm.

Here is a a demonstration of my situation(all from the same video):
https://youtu.be/gFN_H2i2TZ8?t=1m21s
https://youtu.be/gFN_H2i2TZ8?t=1m34s
https://youtu.be/gFN_H2i2TZ8?t=1m42s
https://youtu.be/gFN_H2i2TZ8?t=18m24s

The video shown has the strongest symptoms of the situation. Although it seems loading screens are the cause, I have had these symptoms in other cases where the action was fluid and did not involve loading time.

Here are the settings that I use:
screenshot1.png
screenshot1.png (113.01 KiB) Viewed 5940 times

screenshot2.png
screenshot2.png (110.17 KiB) Viewed 5940 times

screenshot3.png
screenshot3.png (138.34 KiB) Viewed 5940 times


What I tried so far:
- changed from mp4 to avi but this loses video quality
- downgraded from 48000 to 41000 Hz with no change
- checked "skip recording while frame is not updating" but this introduces a difference between the length of video versus the 2 audio tracks

Why do I want/need this setup:
- The image quality is perfect. I only obtain this kind of quality if I use Motion JPEG with 100 quality setting but that produces massive files.(I edit with Sony Vegas)
- the performance in games is not influenced(yeeeeiiii!)
- I edit the audio track from the microphone separately from the in-game one. This allows me greater control over noise cancelling and volume balance between tracks. Related to this: I have also observed very rare, half a second screech/static noises in the audio of the game.

It seems that the audio is somehow recorded in the relation with the FPS of the video and if there is a dip in fps then the audio stops and compensates by doubling the last part that it missed.

Thank you very much for your time!

My pc specs:
Operating System
Windows 7 Ultimate 64-bit SP1
CPU
Intel Core i5 3570K @ 3.40GHz 52 °C
Ivy Bridge 22nm Technology
RAM
8.00GB Dual-Channel DDR3 @ 667MHz (9-9-9-24)
Motherboard
Gigabyte Technology Co., Ltd. Z77X-D3H (Intel Core i5-3570K CPU @ 3.40GHz) 28 °C
Graphics
E2242 (1920x1080@60Hz)
E2242 (1920x1080@60Hz)
Intel HD Graphics 4000 (Gigabyte)
2047MB NVIDIA GeForce GTX 660 (Gigabyte) 44 °C
Storage
111GB KINGSTON SH103S3120G SCSI Disk Device (SSD) 35 °C
931GB Western Digital WDC WD10EZEX-00RKKA0 SCSI Disk Device (SATA) 41 °C
931GB Western Digital WDC WD10EZEX-60M2NA0 SCSI Disk Device (SATA) 35 °C
Optical Drives
ZCTSJEX FSTE3W5Q3C SCSI CdRom Device
DTSOFT Virtual CdRom Device
Audio
VIA High Definition Audio
Samson C03U

damnedsky
Posts: 4
Joined: Sat Jul 25, 2015 1:14 am

Re: Audio snags in recordings when using AAC codec

Tue Jul 28, 2015 4:15 pm

I can confirm it also does it with the latest version 2.2.5. Here is a small clip that I did on The Witcher 3 Wild Hunt while browsing through the menus: http://youtu.be/PNtnQkibQEU

damnedsky
Posts: 4
Joined: Sat Jul 25, 2015 1:14 am

Re: Audio snags in recordings when using AAC codec

Wed Aug 05, 2015 6:03 am

After more recording sessions it seems that the snags are also related to the Keyframe Interval used by the codec:
Capture.PNG
Capture.PNG (115.5 KiB) Viewed 5889 times

With lower numbers there are fewer snags but the file size is also greater. The effect is stronger when changing between gameplay and character inventory(both in The Witcher 3 and Minecraft).

I have also changed the Framerate mode to "Prefer CFR" hoping that this would reduce the audio snags but I am afraid this does not help very much.
Capture1.PNG
Capture1.PNG (108.82 KiB) Viewed 5889 times

User avatar
Bandicam Company
Site Admin
Posts: 6703
Joined: Mon Dec 20, 2010 12:19 pm

Re: Audio snags in recordings when using AAC codec

Fri Aug 07, 2015 1:59 pm

Hello!

Your audio is good enough.
We have no idea what your audio problem is.

Our recommendations are as follows:
1. Check the "Two Sound Mixing" option, and try it again.
2. Uncheck "Skip recording while frame is not updated", and try it again.
3. Choose the "Prefer CFR" option, and try it again.
4. Change the FourCC code from H.264 to X.264 and the keyframe interval from 150 to 1, and then try it again.

Dfactor
Posts: 215
Joined: Wed Sep 18, 2013 7:14 am

Re: Audio snags in recordings when using AAC codec

Sat Aug 08, 2015 4:54 am

Checked those 60 seconds and it seems that the 2nd audio track (microphone) skips, stutters and loops (audio buffer and/or driver issues?).
Seems like an uncommon issue.

User avatar
Bandicam Company
Site Admin
Posts: 6703
Joined: Mon Dec 20, 2010 12:19 pm

Re: Audio snags in recordings when using AAC codec

Mon Aug 10, 2015 5:39 pm

Now, we understand what your problem is.
Thank you Dfactor!

It might be a microphone delay issue.

* Some solutions.

1. If you change your microphone, you may be able to solve the problem.

2. Choose "WinVista/7/8 Sound (WASAPI)" as the primary sound device, and disable the secondary sound device (Your microphone), and check "Listen to this device" and try it again.
Image
Image
Image

3. Check the "Two Sound Mixing" option, and try it again.

damnedsky
Posts: 4
Joined: Sat Jul 25, 2015 1:14 am

Re: Audio snags in recordings when using AAC codec

Mon Aug 17, 2015 3:11 am

Hey guys! Thank you for your response and sorry for such a delayed response from my part!

Unfortunately I cannot do what you ask with with „listen to this device” because that would merge my audio and game sound and I don't want that. BUT I did switch my settings to AVI instead of mp4, and PCM audio codec instead of AAC, and the audio snags seems to NOT occur anymore. These setting also seem to stop any weird video artifacts from producing in the AVI(which was my initial problem with switching to AVI)

Thank you again for your time! Cheers!

Capture.PNG
Capture.PNG (115.77 KiB) Viewed 5808 times

Return to “Bandicam - General Discussion”

Who is online

Users browsing this forum: Google [Bot] and 10 guests