Nigan
Posts: 2
Joined: Sat May 25, 2019 1:32 am

Bandicam does not recognize Elgato HD60 S

Mon May 27, 2019 4:58 pm

Hello everyone,,
I've got this camera: http://www.sony.com/electronics/handyca ... vg30-vg30h

Connected through this dongle: https://www.elgato.com/en/gaming/game-capture-hd60-s

Trying to record in 1080p @60fps.

Bandicam says "the device could not be initialized' or some similar error, I don't remember the exact wording off the top of my head.

I'm able to record using OBS, or XSplit, or Elgato's proprietary softrware, no problem. But Bandicam doesn't even see the capture device.

When I bring up the properties, it lists something called the Elgato Helper Device (which does nothing when selected) and that's it. It does not list the Elgato HD 60 s.

Any advice?

User avatar
Bandicam Company
Site Admin
Posts: 6358
Joined: Mon Dec 20, 2010 12:19 pm

Re: Bandicam does not recognize Elgato HD60 S

Tue May 28, 2019 12:21 pm

Hello Nigan,

Elgato HD60 S capture device should be recognized by Bandicam 4.3.1 or higher.
First, please uninstall the current version of Bandicam and download and install the latest version of Bandicam.
https://www.bandicam.com/downloads/

Also, please download and install the latest webcam driver.

If you still have the problem, please get back to us with the information below.

1. Do you have the same issue with the webcam overlay function?
2. Please attach the screenshot of the Bandicam Device settings window with all the format options opened.

Thank you.

Return to “Bandicam - General Discussion”

Who is online

Users browsing this forum: MSN [Bot] and 18 guests