Peter Smith
Posts: 1
Joined: Fri Oct 23, 2020 3:46 am

"What U Hear" secondary audio using SBZ microphone

Sat Oct 24, 2020 5:08 am

Sometimes I am getting echoes when I use the latest Bandicam for recording a Webcam along with "What U Hear" secondary audio enabled. There are two cases I am considering here. In the first case, my initial objective was to play an audio file from my computer while I am recording a webcam video of me and my voice.

"What U hear" worked fine for secondary audio when using the microphone integrated with my Microsoft webcam.

Initially, "What U hear" did not work correctly when using my Soundblaster Z (SBZ) microphone. I got an approximately 1 second delay of my voice playing back through the computer speakers, even before the recording was turned on. This corrupted the recording. Using headphones did not help, so the effect was electronic, in the computer or sound card, not accoustic. No combination of settings in either the Bandicam or the Creative SBZ control panels and rebooting the computer would eliminate the echo. "Listen to this device" is disabled, so it couldn't have been that.

On an unrelated matter, I decided to register my Bandicam license. Surprise! Now "What U hear" secondary audio works with the SBZ microphone. I don't understand how this could have fixed it. Any idea?

In the second case, I tried a screen recording with secondary audio and my picture in the lower right corner. That worked great for normal audio and screen navigation. I could play audio files on the computer, and they sounded just fine on playback of the screen recording, including my voice-over.

Then, in the recording session, I tried to play a previously-recorded Bandicam video -- a video within a video. That caused it to have a different kind of echo. While I was making the recording, the video being played-back sounded just fine. However, when playing the video-in-video Bandicam recording back, it sounded like the video's sound was inside a tin can. It was poor sound with an echo, not just a simple delay-echo as before. The voice-over part, my voice, was clear.

Am I simply going past the capabilities of Bandicam with video in video, or is there some way I could try to fix this? Again, normal capture of webcam videos with secondary audio work fine. My only problem now is trying to capture a Bandicam video playing within a screen-capture video. Hope that is not too confusing. :D

Return to “Bandicam - General Discussion”

Who is online

Users browsing this forum: Bing [Bot] and 32 guests