gdgsdg123
Posts: 49
Joined: Thu Mar 28, 2019 4:16 am

Bandicut 3.1.5.511, problem decoding videos of computationally intensive encoding settings

Mon Oct 21, 2019 3:23 pm

Upon the file is opened, either a "Colorful Screen" presented in the video area or obvious visual glitches presented on the video display.


Sample files:
(generated in the below manner)

Code: Select all

ffmpeg -i "INPUT_5120x1440@30" -an -c:v libx264rgb -preset placebo -qp 0 -x264-params "keyint=15:no-deblock=1" -flags +bitexact -fflags +bitexact -map_metadata -1 "rgb.mkv"

Code: Select all

ffmpeg -i "INPUT_5120x1440@30" -an -c:v libx264 -preset placebo -qp 0 -x264-params "keyint=15:no-deblock=1" -pix_fmt yuv444p -sws_flags spline+accurate_rnd+full_chroma_int+bitexact -color_range 1 -colorspace 5 -color_primaries 5 -color_trc 6 -flags +bitexact -fflags +bitexact -map_metadata -1 "i444.mkv"

Code: Select all

ffmpeg -i "INPUT_5120x1440@30" -an -c:v libx264 -preset placebo -qp 0 -x264-params "keyint=15:no-deblock=1" -pix_fmt yuv444p10le -sws_flags spline+accurate_rnd+full_chroma_int+bitexact -color_range 1 -colorspace 5 -color_primaries 5 -color_trc 6 -flags +bitexact -fflags +bitexact -map_metadata -1 "i444_10.mkv"

Code: Select all

ffmpeg -i "INPUT_5120x1440@30" -an -c:v libx264 -preset placebo -qp 0 -x264-params "keyint=15:no-deblock=1" -pix_fmt yuv420p -sws_flags spline+accurate_rnd+full_chroma_int+bitexact -color_range 1 -colorspace 5 -color_primaries 5 -color_trc 6 -flags +bitexact -fflags +bitexact -map_metadata -1 "i420.mkv"

Code: Select all

ffmpeg -i "INPUT_5120x1440@30" -an -c:v libx264 -preset placebo -qp 0 -x264-params "keyint=15:no-deblock=1" -pix_fmt yuv420p10le -sws_flags spline+accurate_rnd+full_chroma_int+bitexact -color_range 1 -colorspace 5 -color_primaries 5 -color_trc 6 -flags +bitexact -fflags +bitexact -map_metadata -1 "i420_10.mkv"

The "i420" variants may end in visual glitches, while the rest always end in "Colorful Screen".

Changing the container format doesn't seem to make any difference. (tried: AVI)

Triggering of the problem may be related with system performance. (with "INPUT_1920x1080@30" and the rest the same, it doesn't seem to occur)



Sample preview:
https://www.youtube.com/watch?v=EmRifcgoEm0

Return to “Bandicut - General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest