User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

HUGE Lag spike when recording CBR mpeg1

Sun Nov 29, 2015 5:08 am

Every time I try to record battlefront with bandicam - mpeg1 CBR it spikes the fps really hard for about 20 seconds and its really anoyying.
That is the only codec that I can use, and vbr is not an option for me.
Help?
Thanks!

User avatar
Bandicam Company
Site Admin
Posts: 6679
Joined: Mon Dec 20, 2010 12:19 pm

Re: HUGE Lag spike when recording CBR mpeg1

Mon Nov 30, 2015 2:22 pm

Do you have the issue with other games?

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Mon Nov 30, 2015 8:51 pm

Yes.
I sort of fixed it by switching bandicam's priority to low, but now i noticed another really annoying problem which is really choppy video.
I record on VBR mode(meaning that it's not CFR), CBR And 60FPS.
I have a really good computer(OC 980ti) and i usually get around 170FPS in game.

User avatar
Bandicam Company
Site Admin
Posts: 6679
Joined: Mon Dec 20, 2010 12:19 pm

Re: HUGE Lag spike when recording CBR mpeg1

Tue Dec 01, 2015 10:31 am

Hello!

Why don't you use the "H.264 (NVIDIA NVENC)" encoder?
What are the names of the games?

but now i noticed another really annoying problem which is really choppy video.

Could you send a short video clip to bandicam@bandisoft.com?

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 2:07 am

I can't use the H.264 codec since i'll have problems with it and Premiere, and even if i turn CFR on, there's still a high chance of audio desyncing.
The game is Battlefront.

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 2:30 am

Here is the video, which i also sent to your email:
https://www.youtube.com/watch?v=2Rpl1S4 ... e=youtu.be

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 2:33 am

It might not seem so obvious in youtube, but when i view it in a video player such as VLC or Media Player, or even Premiere, it looks very choppy and bad.
Also, bandicam is always telling me the FPS that the media player is playing in, and it's almost always on 60fps, even when the footage itself is choppy, suggesting it's not the player's fault.

User avatar
Bandicam Company
Site Admin
Posts: 6679
Joined: Mon Dec 20, 2010 12:19 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 12:20 pm

If you choose the "Motion JPEG and PCM" codecs, you can edit the recorded video with Adobe Premiere and fix choppy videos.

Image

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 3:05 pm

As i said in the email, if there was a way to convert the value of CBR to VBR, i would use Motion JPEG, but right now i can't really figure a similar value to what i had on MPEG.
Are you sure there's no way to fix the problem with MPEG?

User avatar
Bandicam Company
Site Admin
Posts: 6679
Joined: Mon Dec 20, 2010 12:19 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 5:21 pm

I can't use the H.264 codec since i'll have problems with it and Premiere, and even if i turn CFR on, there's still a high chance of audio desyncing.


Have you tried both the AVI and MP4 container?

- If you used the "H.264 (NVIDIA NVENC)" and "PCM" (.AVI) with the CFR option, please try "H.264 (NVIDIA NVENC)" and "AAC" codecs (.MP4).

- If you used the "H.264 (NVIDIA NVENC)" and "AAC" (.MP4) with the CFR option, please try "H.264 (NVIDIA NVENC)" and "PCM" codecs (.AVI).

Image

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Wed Dec 02, 2015 7:27 pm

I've tested all bandicam's codecs to see what fits me, and the only one's that worked 100% were Motion Jpeg and MPEG.
I've also tested all of the codecs with CFR.

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Fri Dec 04, 2015 3:14 pm

So i'm pretty sure that i figured it out.
The method i'm using is with x264vfw, and a few commands.
Here's a picture of what the x264vfw configuration screen looks like:
http://i.imgur.com/yknmWDH.png
I've set the rate control to Multipass - nth, so that file sizes would stay the same, and so far the file sizes are about 60% of the file time, and the quality is really good.
There are no problems with editing as long as you put in the extra command line "--keyint 1" and "--pass 0".

User avatar
Bandicam Company
Site Admin
Posts: 6679
Joined: Mon Dec 20, 2010 12:19 pm

Re: HUGE Lag spike when recording CBR mpeg1

Fri Dec 04, 2015 4:22 pm

Thank you very much for your feedback.

If you were able to solve the issue with the settings above, the solution below may also work:

1. Choose the 'AVI' container, and select "H264 (NVIDIA NVENC)" and "PCM" codecs.

2. Click the [...] button of video codec, and change "FourCC code" from "H264" to "X264".
Image


Please let us know your result.

User avatar
YonatanZamir
Posts: 52
Joined: Sun Jan 11, 2015 4:54 pm

Re: HUGE Lag spike when recording CBR mpeg1

Fri Dec 04, 2015 8:45 pm

I've already tried it, and i'm pretty sure it would work, but premiere doesn't accept the H.264 AVI codec at all for me.

Return to “Bandicam - General Discussion”

Who is online

Users browsing this forum: No registered users and 16 guests